This documentation corresponds to a historical version of Yellowfin

Icon

Access the latest release, or view a list of available versions of the documentation.

Skip to end of metadata
Go to start of metadata

Overview

Having created our view we are now ready to create reports using the Report Writer. When creating a new report you will have begin with an initialisation step. The step is required for you to select the source system and the view you wish to access, as well as the type of builder you wish to use.

Create New Report

1. Click the Create link on the main Yellowfin navigation - this will open the Initialise Report page.

2. On the Initialise Report page select to use the Drag and Drop Builder.

3. Click on the Ski Team as View.

4. This will open the Report Data page. From this page you will be able to define all your report components.

See Report Builder for more information.

Column Report with an Advanced Function

This example report is a column report including an advanced function applied to a field and an alert to highlight exception data.

1. Open the Payment and Time categories using the expand icon to see the fields.

2. From the Time folder drag the Year field into the Columns panel.

3. From the Payment category drag the Invoice Estimate into the Columns panel below Year.

You will notice that this field now has a sum symbol on it. This means that the field will be aggregated, as a default aggregation of Sum was defined at the View level.

4. Click the Next button to run the report and view your data.

5. Click the drop down menu link on the Sum Invoice Estimate column.

6. This will open the drop down menu. Select Sum Total.

7. The report will now refresh and a total will be displayed for the Sum Invoiced Estimate column.

To add new columns and add drill down support you will need to edit the report data.

8. Click the Edit button on the main report menu and select the Data option.

9. The Report Data page should now open. On the Report Options menu in the Analysis Section click the Drill Down radio button.

This will enable drill down for the time hierarchy.

10. From the Payment folder drag in another instance of the Invoice Estimate field

11. Click the advanced function button while the field is selected to apply an Advanced Function

12. In the advanced format popup select Percentage of Total from the list.

13. Click Save to save the change and return to your data page.

14. The icon for this field will now be green instead of blue which indicates that the advanced function has been applied.

15. Click the Next button to run the report and view your data.

16. You will notice that the format of the advanced function still uses a $ prefix and not a % suffix.

17. Click the Column menu drop down and select Format Column

18. You will now see that the main menu has changed from Report to Column and the Display menu has opened.

19. Remove the $ Prefix and add a % into the Suffix box. Click the Save button.

20. You will now see the new formatting applied to the column

21. Click the 2006 Link to test the drill down from Year to Quarter.

You will see the Year column is replaced with a Quarter data for that year.

22. To highlight data using Conditional Formatting click the drop down menu icon on the % of Total column.

23. Select Conditional Formatting from the drop down menu

24. Click the Add Rule Link on the edit panel.

25. Select Display style as Cell and Type as Value.

26. Choose the Style as red from the colour picker, for the rule choose Less than and for the value enter 15

27. Click Save to Close the form and update your report.

28. Your report should be refreshed and the % of Total should have cells highlighted in RED where the value is less than 15.

29. To save your report, click the Report icon from the menu bar and Save from the drop down menu. Give the report a name % of total, a description This report was created using the Introductory Tutorial, and save it into the Tutorial and Formatting Categories.

30. Click Activate to publish the report.

See Advanced Functions for more information.

Cross Tab Chart Report

A cross tab report is a good way to present 3 dimensional data. In this example we create a cross tab and render it as a chart rather than a table.

1. Create a new report as described earlier.

2. Select Table and Chart under Output Options in the Report Options section.

Select Cross Tab under Data Output and you will notice that the layout of the report data changes – row and metric fields are introduced.

Select Drill Down under the Analysis section.

3. Open the Payment, Athlete and Time categories using the expand icon to see the associated fields

4. Add the Demographics field as a Column, the Year field as a Row, and the Invoice Estimate field as a Metric.

5. Click the Next Button to progress to the output page and the chart builder.

6. On the output page you will see the chart placeholder image. Click on this to open the Chart Builder.

7. You will now see chart format options. Open the Chart menu.

8. Select the Stacked Vertical Bar type.

9. Click the Save button to start setting up the chart.

10. Based on your chart selection and the data available you will see the Chart Data options.

11. For the Label select Year, Series Sum Invoiced Estimate, and Colour Demographic

12. Click Refresh to see your chart.

13. To add some formatting to the chart, add some coloured bands. Click the Gridlines drop down panel.

14. Select a light grey for the Band Colour from the colour picker.

15. Select 30% opacity for the band.

16 Click Save to see the changes reflected on your chart.

17. You will now see grid bands applied to your chart.

18. Click Close on the chart menu to return to the main report page.

19. Save your report as before, seting the name to Drill Down Chart, description to This report was created using the Introductory Tutorial, and the Sub Category to Charts.

20. Click Activate to publish the report.

See Table Layout Options for more information.

Filtered Section Report & Export to PDF

Using the filters and sections you can determine the data that is displayed in a report and how your data is to be grouped. In this example you will create a report which is sectioned by Gender.

1. Create a new report as described earlier.

2. Add the Year and Invoiced Estimate fields as Columns.

3. Add Demographic to the Filters panel.

4. Add Gender to Sections.

5. In the properties give the report a name of Section Report and description of A section report with user prompt filter created using the Introductory Tutorial.

6. Click the Next button to navigate to the filters step of the builder.

7. From the operator drop down list for the Demographic filter select In List

8. Click the next button to go to the Report Preview page.

9. You will see a list to enter values. Click the prompt icon to search for possible values.

10. A pop box will open and display all the possible values for the selected fields. Select Adventure and Sport.

11. Click Submit to close the popup.

12. Click the Go button under the filter box to run the report. Your restricted results will be returned.

13. Add totals to the sections. Firstly using the column drop down menu add a Sum Total to Sum Invoice Estimate.

14. Next click the Section link on the main menu. This will open the section format options.

15. Select the Summary menu and select Yes for Grand Totals. Click Save to close and save your changes.

16. Your report will now have grand totals for the sections as shown here.

17. We will export this report to PDF, but first we want to ensure that our Filter values are displayed on external output.

18. Click on the Filters tab at the top of the page, open the Format menu and set the Display Filter Values option to Bottom. Save

19. Now select the Export link drop down and choose the Export to PDF option.

20. Select the appropriate export options for PDF and click OK to export.

21. Follow the instructions of your browser to save your PDF locally.

22. Once saved to your hard drive open the PDF to view the results of your report.

23. Save and activate your report for later use.

See Filters, Sections, and Exporting Your Report for more information.